CakePHP 2.8.3 ya suite TEST (PHPUnit)

Preguntas RecientesCategoria: PHPCakePHP 2.8.3 ya suite TEST (PHPUnit)
fitorec preguntada 1 año antes

CakePHP 2.x no trabaja de forma correcta con la versión mas reciente de PHPUnit, la documentación oficial de cakePHP recomienda usar la versión 3.7.38, explico como instalar esta dependencia en la versión del cakePHP 2.8.3 para empezar hacer nuestras propias pruebas.
 
Descargando e instalando el PHPUnit:
Nos posicionamos en nuestra carpeta app/Vendor y ejecutamos:

wget https://phar.phpunit.de/phpunit-3.7.38.phar -O phpunit.phar
chmod +x phpunit.phar

 
Probando la configuración:
Una vez que se instala el PHPUnit podemos acceder desde nuestro navegador en: http://localhost/tu_app/test.php o bien puedes acceder en la linea de comandos usando el shell del cakePHP.

Your Answer

6 + 9 =