Cambiar nivel de api para android en phonegap

Preguntas RecientesCategoria: OtroCambiar nivel de api para android en phonegap
benito juarez preguntada 1 año antes

quiero que mi app que haga con android se compile para GINGERBREAD que es nivel de api 9 segun la pagina de android cuando uso el comando

phonegap build android 

lo compila con un nivel de api de 22 que es el que trae por default, como cambio eso

1 Respuestas
drozz contestada 1 año antes

las versiones de phonegap mas recientes ya no usan esos niveles de api, el nivel de api mas bajo que he utlizado es 14 ICE_CREAM_SANDWICH que su plataforma es android 4.0.0, para usar este nivel de api en tu proyecto ya creado en phonegap primero tienes que agregar la plataforma android especificamente con ese numero

 phonegap platforms add android@4.0.0  

despues editas estos archivos en tu app:
tuApp/platforms/android/project.properties
tuApp/platforms/android/CordovaLib/project.properties
y cambias su campo “target=android-22” por “target=android-14” ademas de cambiar tambien el archvo manifiesto en tu app

<uses-sdk android:minSdkVersion="9" android:targetSdkVersion="14" />

Your Answer

18 + 6 =